Solutions

Search  Users  Rules 
Close
Login:
Password:
Forgot your password?
Register
Login Register
 
Pages: 1
RSS
LVE Manager blank in WHM and LVETOP shows no information
I have installed and booted into the cloudlinux kernel however I am not able to see any information either in the lvetop command or using the WHM CloudLinux LVE Manager.

I believe it has something to do with mod_hostinglimits either not installing or being captured by Apache. Any suggestions or advice would be greatly appreciated.
Joe,

Could you post output of:
uname -r
/etc/init.d/httpd -M|grep hosting
Thanks for the reply. Here is the output:

# /etc/init.d/httpd -M|grep hosting
Warning: DocumentRoot [/home/service/public_html] does not exist
Warning: DocumentRoot [/home/service/public_html] does not exist
Syntax OK

# uname -r
2.6.18-338.12.1.el5.lve0.8.34PAE
Joe,

mod_hostinglimits is not installed.
If you are running cPanel 11.30 -- please, recompile Apache via EasyApache. You can do it via WHM, or by running: /scripts/easyapache --build

If you are running cPanel 11.28 -- please, run yum install cpanel-lve
I did try the /scripts/easyapache --build method, no results. When attempting to use WHM, should I see an option to include mod_hostinglimits in the build list? I am running WHM 11.30.1 (build 4)
CLOUDLINUX 5.6 i686 standard.
no, there is no option. EasyApache detects cloudlinux/includes it automatically.
Could you check if you have lve-stats RPM installed? You can do it via rpm -qa|grep lve
The package should be one of the listed packages.

Also, could you check that easyapache doesn't fail with some error. I have seen it as a reason for mod_hostinglimits not being installed.
If it doesn't -- please, submit a ticket at helpdesk.cloudlinux.com, with server access info -- and we will check.
I do have lve-stats installed:

# rpm -qa|grep lve
kernel-PAE-2.6.18-338.12.1.el5.lve0.8.34
lve-0.8-20
liblve-0.8-20
liblve-devel-0.8-20
lve-utils-0.6-6.el5.cloudlinux
kernel-PAE-devel-2.6.18-338.12.1.el5.lve0.8.34
lve-stats-0.5-18.el5.cloudlinux

I will run the WHM version and see if it errors out. If I still have no success, I will submit a ticket. Thank you for your help, Igor.
It did error out the easy apache build via WHM. I will submit a ticket with cPanel to have them investigate that issue as well.

Here is the output regarding it fr om the easy apache log:

chmod 755 /usr/local/apache/modules/mod_disable_suexec.so
-- End step 'APXSing mod_disable_suexec' --

-- Begin step 'APXSing mod_hostinglimits' --
/usr/local/apache/build/libtool --silent --mode=compile gcc -prefer-pic -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -pthread -I/opt/pcre/include -I/usr/local/apache/include -I/usr/local/apache/include -I/usr/local/apache/include -DAPACHE2_2 -DLVE_DEPRICATED -c -o . ./mod_hostinglimits.lo . ./mod_hostinglimits.c && touch . ./mod_hostinglimits.slo
. ./mod_hostinglimits.c:19:1: warning: "LVE_DEPRICATED" redefined
<command line>:1:1: warning: this is the location of the previous definition
In file included fr om . ./mod_hostinglimits.c:48:
/usr/include/lve/lve-ctl.h:126:2: warning: #warning you need remove old functions
. ./mod_hostinglimits.c:764:2: warning: #warning "apr_lve_environment_init mode enabled!!!"
/usr/local/apache/build/libtool --silent --mode=link gcc -o . ./mod_hostinglimits.la -llve -rpath /usr/local/apache/modules -module -avoid-version . ./mod_hostinglimits.lo
/usr/local/apache/build/instdso.sh SH_LIBTOOL='/usr/local/apache/build/libtool' . ./mod_hostinglimits.la /usr/local/apache/modules
/usr/local/apache/build/libtool --mode=install cp . ./mod_hostinglimits.la /usr/local/apache/modules/
cp . ./.libs/mod_hostinglimits.so /usr/local/apache/modules/mod_hostinglimits.so
cp . ./.libs/mod_hostinglimits.lai /usr/local/apache/modules/mod_hostinglimits.la
cp . ./.libs/mod_hostinglimits.a /usr/local/apache/modules/mod_hostinglimits.a
chmod 644 /usr/local/apache/modules/mod_hostinglim its.a
ranlib /usr/local/apache/modules/mod_hostinglim its.a
PATH="$PATH:/sbin" ldconfig -n /usr/local/apache/modules
no, none of it looks like an error, and it seems mod_hostinglimits was installed.
Could you run this again:

/etc/init.d/httpd -M|grep hosting
It did error out at the bottom of the report:

Failed to utilize existing Apache configuration file. Resetting Apache configuration to default. !!
Distilled successfully
!! Failed to generate a syntactically correct Apache configuration (/usr/local/apache/conf/httpd.conf.1312297085):
An error occurred while running: /usr/local/apache/bin/httpd -DSSL -t -f /usr/local/apache/conf/httpd.conf.1312297085
Exit signal was: 0
Exit value was: 1
Output was:
---
Warning: DocumentRoot [/home/service/public_html] does not exist
Syntax error on line 51818 of /usr/local/apache/conf/httpd.conf.1312297085:
SSLCACertificateFile: file '/etc/ssl/certs/********.**************.com.cabundle' does not exist or is empty
---
!!
!!


and when /etc/init.d/httpd -M|grep hosting i get the same output:

# /etc/init.d/httpd -M|grep hosting
Warning: DocumentRoot [/home/service/public_html] does not exist
Warning: DocumentRoot [/home/service/public_html] does not exist
Syntax OK

I have sent a request over to cPanel along with the build log from the easy apache build attempt in hopes they can take a look at that side of it.
Yep, this is the error: SSLCACertificateFile: file '/etc/ssl/certs/********.**************.com.cabundle' does not exist or is empty

plz, check with cPanel guys -- they should be able to fix it in no time.
Thanks again for your help, Igor. I really do appreciate it. :)
I am happy to report that the errors were cleared and the mod_hostinglimits module was installed successfully. All I can say is WOW!! The results are absolutely amazing with having cloudlinux running!! Thank you again for all of your help and thank you for such a wonderful product!
Hello sir,

Am having the same issue after installing cloudlinux in the server. Nothing gets listed in WHM CloudLinux LVE Manager and also the stats in the cpanel for each account doesn't shows details for cpu usage and entry process. All the value seems to be 0 ( 0/100 , 0/20 ). Is it any issue related to mod_hostinglimits? The output for /etc/init.d/httpd -M|grep hosting in my server is :

# /etc/init.d/httpd -M|grep hosting
Syntax OK
hostinglimits_module (shared)
Hello,

I have also tried recompiling apache after the cloudlinux installation !
Everything seems to be fine. Do you have live traffic on that server? Anyone hitting php/cgi pages?
Another thing to check is if suexec is enabled. (/etc/init.d/httpd -M|grep suexec)
Also, don't hesitate to contact our support if you want us to check your server.
We just had the same problem ourselves. (no LVE data displayed in WHM or cpanel)

The problem was that apache was not properly recompiled with the "mod_hostinglimits" apache module.

So it might be good for the cloudlinux installation process to check that automatically and report to admin if it is missing. From this post, it seems a popular problem, and is easy to fix once you know what to look for. :)

... And yes, I can also agree that the results after installation of cloud linux on our test server is absolutely amazing. It works exactly as advertised. I'm very impressed so far.
Pages: 1
Users browsing this topic (1 guests, 0 registered, 0 hidden)