Solutions

Search  Users  Rules 
Close
Login:
Password:
Forgot your password?
Register
Login Register
 
Pages: 1
RSS
Installation problems with Cloud Linux
Hey guys,

I've been trying to install Cloud Linux on CentOS 5.6 following the instructions. Basically it all worked fine until I got to checking for LVE in WHM.

Some information on where things are currently at:

uname -a
Linux Server 2.6.18-194.32.1.el5 #1 SMP Wed Jan 5 17:53:09 EST 2011 i686 i686 i386 GNU/Linux

cat /etc/redhat-release
CloudLinux Server release 5.6

rpm -qa|grep lve
Outputs nothing

I have tried to rerun centos2cl and get the following:

Installing lve...
Loaded plugins: fastestmirror


Error getting repository data for cloudlinux-i386-server-5, repository not found
New cPanel installed, no extra packages needed
!!!Important: Memory limits are disabled by default.
To enable memory limits, please run:
# lvectl ubc enable --save

-bash: lvectl: command not found

Googling the error results in no help.

I've rebooted after running sh centos2cl -k like it said, and I do have a valid license purchased through cPanel for the servers IP address.

I've tried plenty of things like yum install cpanel-lve, yum install cpanel-lvemanager, basically anything I could google but none helped, all result in saying that there is no such package.

I've also recompiled apache through WHM's easy apache as I read this was required for mod_hostinglimits, I am assuming this is done is there anyway I can check the module is there? It doesn't appear in httpd -l

Not sure if related, while running sh cpanel2cl -k I noticed that the repositories were all 64 bit?

Any help would be great, thanks.
Edited: Bob Tatus - 29.12.2011 11:38:36
What is the output of:
rpm -qa|grep lve
/usr/sbin/rhn_check
rpm -qa|grep lve - this outputs nothing, so it's as if it isn't actually installed yet. It still says cloud linux in the redhat-release and in WHM though.

/usr/sbin/rhn_check - this doesn't seem to exist.
Could you give complete output of cpanel2cl -k
Also, feel free to contact our support -- we would be happy to help.
root@server [~]# sh cpanel2cl -k
Loaded plugins: fastestmirror
Cleaning up Everything
Cleaning up list of fastest mirrors
Loaded plugins: fastestmirror
Cleaning up Everything
Retrieving http://repo.cloudlinux.com/cloudlinux/migrate/i386/CloudLinux/cloudlinux-release-5-6.noarch.rpm
Retrieving http://repo.cloudlinux.com/cloudlinux/migrate/x86_64/CloudLinux/cloudlinux-logos-0.3-1.el5.1.noarch.rpm
Preparing... ########################################### [100%]
1:cloudlinux-logos ########################################### [ 50%]
2:cloudlinux-release ########################################### [100%]
Loaded plugins: fastestmirror
Determining fastest mirrors
* cloudlinux-updates: repo.cloudlinux.com
* cloudlinux-base: repo.cloudlinux.com
cloudlinux-updates X | 1.1 kB 00:00
primary.xml.gz X | 59 kB 00:00
cloudlinux-updates X 140/140
cloudlinux-base X | 1.1 kB 00:00
primary.xml.gz X | 59 kB 00:00
cloudlinux-base X 140/140
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
No package yum-rhn-plugin available.
Nothing to do
Registering... cpanel2cl: line 213: /usr/sbin/clnreg_ks: No such file or directory
Success
Installing lve...
Loaded plugins: fastestmirror


Error getting repository data for cloudlinux-i386-server-5, repository not found
New cPanel installed, no extra packages needed
!!!Important: Memory limits are disabled by default.
To enable memory limits, please run:
# lvectl ubc enable --save
Ignore error message that you will receive.

---

When trying to do lvectl ubc enable --save, I get -bash: lvectl: command not found
Could you plz show me content of /etc/yum.conf
I think there is yum* or something similar there, preventing yum-rhn-plugin from being installed.
[main]
exclude=apache* bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mysql* nsd* perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail* yum*
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

installonly_limit = 5

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
Please, remove yum* from exclude line, and try again. That should help it.
That's much better looking, it actually tried to install lots of stuff. The server registered, and then..

Complete!
Registering... Profilename: servername
Success
Installing lve...
Loaded plugins: fastestmirror, rhnplugin


Error getting repository data for cloudlinux-i386-serv, repository not found

Same as before? Or is that fine and I should reboot?
Please, try to do following:
/etc/rpm/platform should be created with line

i686-redhat-linux

Then re-run install script.
It looks like it already had this there:

[/etc/rpm]# cat platform
i686-redhat-linux
I guess we would need access to the server :( Could you contact our support?
No problem, ticket submitted thanks for the help. 8)
Issue seems to be resolved, I tried the exact same process again and it just worked, like the repo was suddenly available - all solved.
Pages: 1
Users browsing this topic (2 guests, 0 registered, 0 hidden)