CloudLinux OS Blog - Alt-PHP updated
CloudLinux OS Blog

Alt-PHP updated

Alt-PHP updated

New updated Alt-PHP packages are now available for download from our production repository.

Changelog:

alt-php73-7.3.0-1

  • ALTPHP-639: updated SIGTERM cleanup patch;
  • updated alt-php73 to version 7.3.0-1.

alt-php72-7.2.13-1

  • ALTPHP-639: updated SIGTERM cleanup patch;
  • updated alt-php72 to version 7.2.13-1.

alt-php71-7.1.25-1

  • ALTPHP-639: updated SIGTERM cleanup patch;
  • updated alt-php71 to version 7.1.25-1.

alt-php70-7.0.33-1

  • ALTPHP-639: updated SIGTERM cleanup patch;
  • updated alt-php70 to version 7.0.33-1.

alt-php56-5.6.39-1

  • ALTPHP-639: updated SIGTERM cleanup patch;
  • updated alt-php56 to version 5.6.39-1.

alt-php73-pecl-ext-1-1

  • updated alt-php73 to version 7.3.0-1;
  • ALTPHP-625:
    • updated apcu extensions to version 5.1.14;
    • updated redis extensions to version 4.2.0;
    • updated yaml extensions to version 2.0.3;
    • added swoole extensions to version 4.2.9;
    • added libsodium extensions to version 2.0.15.

alt-php72-pecl-ext-1-31

  • ALTPHP-626:
    • updated apcu extensions to version 5.1.14;
    • updated redis extensions to version 4.2.0;
    • updated yaml extensions to version 2.0.3;
    • added swoole extensions to version 4.2.9;
    • added libsodium extensions to version 2.0.15.

alt-php71-pecl-ext-1-37

  • ALTPHP-627:
    • updated apcu extensions to version 5.1.14;
    • updated redis extensions to version 4.2.0;
    • updated yaml extensions to version 2.0.3;
    • added swoole extensions to version 4.2.9;
    • added libsodium extensions to version 2.0.15.

alt-php70-pecl-ext-1-49

  • ALTPHP-628:
    • updated apcu extensions to version 5.1.14;
    • updated redis extensions to version 4.2.0;
    • updated yaml extensions to version 2.0.3;
    • added swoole extensions to version 4.2.9;
    • added libsodium extensions to version 2.0.15.

alt-php56-pecl-ext-1-75

  • ALTPHP-631: updated redis extensions to version 4.2.0.

alt-php55-pecl-ext-1-109

  • ALTPHP-630: updated redis extensions to version 4.2.0.

alt-php54-pecl-ext-1-123

  • ALTPHP-629: updated redis extensions to version 4.2.0.

alt-php-config-1-31.1

  • ALTPHP-636: added alt-php73 support to alt-php.cfg;
  • ALTPHP-567: reconfiguration is broken for mysql 8.0.

Update command:

yum groupupdate alt-php
LVE Manager updated
Beta: EasyApache 4 updated
 

Comments 8

Guest - Ryan Smith on Thursday, 13 December 2018 15:06

Will the mysqli and pdo_mysql extensions eventually be released for PHP 7.3?

Will the mysqli and pdo_mysql extensions eventually be released for PHP 7.3?
Guest - Emil Stahl on Sunday, 16 December 2018 18:26

They are called nd_pdo_mysql and nd_mysqli now.. for some reason..

They are called nd_pdo_mysql and nd_mysqli now.. for some reason..
Guest - Ryan Smith on Sunday, 16 December 2018 19:09

The nd_mysqli and nd_pdo_mysql extensions are separate extensions from mysqli and pdo_mysql (both are available for 7.2 and previous PHP versions).

Support said mysqli and pdo_mysql are available in their test environments and should be there, but they are missing from PHP 7.3 across all of my many servers when this Alt-PHP update with 7.3 was installed.

I noticed that the following symbolic links are missing:

/opt/alt/php73/usr/lib64/php/modules/mysqli.so -> /opt/alt/php73/etc/mariadb101/mysqli.so
/opt/alt/php73/usr/lib64/php/modules/pdo_mysql.so -> /opt/alt/php73/etc/mariadb101/pdo_mysql.so

Additionally, these ini files are missing as well:

/opt/alt/php73/etc/http://php.d.all/mysqli.ini
/opt/alt/php73/etc/http://php.d.all/pdo_mysql.ini

Can this please be looked into as it appears to be a widespread issue.

The nd_mysqli and nd_pdo_mysql extensions are separate extensions from mysqli and pdo_mysql (both are available for 7.2 and previous PHP versions). Support said mysqli and pdo_mysql are available in their test environments and should be there, but they are missing from PHP 7.3 across all of my many servers when this Alt-PHP update with 7.3 was installed. I noticed that the following symbolic links are missing: /opt/alt/php73/usr/lib64/php/modules/mysqli.so -> /opt/alt/php73/etc/mariadb101/mysqli.so /opt/alt/php73/usr/lib64/php/modules/pdo_mysql.so -> /opt/alt/php73/etc/mariadb101/pdo_mysql.so Additionally, these ini files are missing as well: /opt/alt/php73/etc/php.d.all/mysqli.ini /opt/alt/php73/etc/php.d.all/pdo_mysql.ini Can this please be looked into as it appears to be a widespread issue.
Guest - Darya Malyavkina on Sunday, 16 December 2018 19:39

You can try to install alt-php73-mysql-meta from cloudlinux-updates-testing repo and update alt-php with this package. This package will be released to stable tomorrow. Could you please notify me about results.

You can try to install [b]alt-php73-mysql-meta[/b] from cloudlinux-updates-testing repo and update alt-php with this package. This package will be released to stable tomorrow. Could you please notify me about results.
Guest - Rich on Tuesday, 08 January 2019 16:47

I have installed alt-php73-mysql-meta, which appears to be the only mysql-related yum package not already installed for php 7.3 but this did not result in any mysql modules being enabled in php 7.3:
===
Installed:
alt-php73-mysql-meta.x86_64 0:2-3.1.el7

Complete!
[root@host 959979]# scl enable alt-php73 "php -m" | grep -i sql
sqlite3
[root@host 959979]# yum list available alt-php73* | grep -i sql
[root@host 959979]# yum list available alt-php73* | grep -Ei "sql|pdo"
[root@host 959979]#
===

It looks like CloudLinux has not yet released an easyapache-compatible package for mysqli in php 7.3?

I have installed alt-php73-mysql-meta, which appears to be the only mysql-related yum package not already installed for php 7.3 but this did not result in any mysql modules being enabled in php 7.3: === Installed: alt-php73-mysql-meta.x86_64 0:2-3.1.el7 Complete! [root@host 959979]# scl enable alt-php73 "php -m" | grep -i sql sqlite3 [root@host 959979]# yum list available alt-php73* | grep -i sql [root@host 959979]# yum list available alt-php73* | grep -Ei "sql|pdo" [root@host 959979]# === It looks like CloudLinux has not yet released an easyapache-compatible package for mysqli in php 7.3?
Guest - Darya Malyavkina on Tuesday, 08 January 2019 17:45

You need to reconfigure mysql:
/usr/bin/alt-php-mysql-reconfigure.py --php 73
if this does not fix the problem, try to reinstall alt-php73-mysql with mysql-governor or contact to support.

You need to reconfigure mysql: [b]/usr/bin/alt-php-mysql-reconfigure.py --php 73[/b] if this does not fix the problem, try to reinstall alt-php73-mysql with mysql-governor or contact to support.
Guest - Rich on Wednesday, 09 January 2019 20:37

Is this still beta, or stable?

Is this still beta, or stable?
Guest - Darya Malyavkina on Wednesday, 09 January 2019 21:07

Are you asking about alt-php73, alt-php-mysql-reconfigure or governor?

So far, cPanel has not released ea-php73. As soon as cPanel released ea-php73, we will also add this package.

Let us continue the discussion by email. dmalyavkina@cloudlinux.com

Are you asking about alt-php73, alt-php-mysql-reconfigure or governor? So far, cPanel has not released ea-php73. As soon as cPanel released ea-php73, we will also add this package. Let us continue the discussion by email. dmalyavkina@cloudlinux.com
Already Registered? Login Here
Guest
Saturday, 23 March 2019

Captcha Image